image

'Mogelijk 4,5 miljoen OpenSSH-servers kwetsbaar voor regreSSHion-lek'

vrijdag 5 juli 2024, 16:20 door Redactie, 5 reacties

Zo'n 4,5 miljoen OpenSSH-servers, waarvan zo'n 95.000 in Nederland, zijn mogelijk kwetsbaar voor het 'regreSSHion'-lek, waardoor een aanvaller op afstand code kan uitvoeren. Dat meldt The Shadowserver Foundation op basis van een online scan. Deze week waarschuwde securitybedrijf Qualys voor een kwetsbaarheid in OpenSSH, met de naam 'regreSSHion', waardoor een ongeauthenticeerde aanvaller op afstand op kwetsbare servers code als root kan uitvoeren.

OpenSSH, ook bekend als OpenBSD Secure Shell, is een verzameling van netwerktools gebaseerd op het SSH-protocol, en laat gebruikers op een beveiligde manier op bijvoorbeeld servers inloggen of op afstand machines beheren. De Shadowserver Foundation is een in Nederland en de Verenigde Staten geregistreerde non-profitstichting die zich bezighoudt met de bestrijding van botnets en cybercrime. Geregeld doet het onderzoek naar de aanwezigheid van kwetsbaarheden op internet en voert hier ook online scans voor uit.

Bij de laatste scan werd gezocht naar CVE-2024-6387, zoals het regreSSHion-lek ook wordt aangeduid. In totaal werden meer dan 23,5 miljoen OpenSSH-servers geteld. Daarvan zijn er mogelijk 4,5 miljoen kwetsbaar. "Aangezien deze scan versiegebaseerd is, zijn zowel false positives en false negatives mogelijk", aldus de stichting op X. Een versiegebaseerde assessment is dan ook minder betrouwbaar. Volgens The Shadowserver Foundation is het in ieder geval belangrijk dat alle beheerders naar OpenSSH 9.8 updaten.

Reacties (5)
05-07-2024, 18:33 door Anoniem
"Aangezien deze scan versiegebaseerd is, zijn zowel false positives en false negatives mogelijk", aldus de stichting op X. Een versiegebaseerde assessment is dan ook minder betrouwbaar. Volgens The Shadowserver Foundation is het in ieder geval belangrijk dat alle beheerders naar OpenSSH 9.8 updaten.

Quatsch. Oudere versies met security patches zijn niet kwetsbaar en v9.8 is niet nodig voor het patchen van kwetsbaarheden.

Als je een domme scan doet op x.y versienummers doe je geen scan waar iets betrouwbaars uit kan komen. Punt. Uit. Klaar.

Kunnen dat soort organisaties zich niet bezig gaan houden met iets waar ze wel verstand van hebben? Dit helpt niet.
06-07-2024, 09:33 door Xavier Ohole
Door Anoniem:
…scan…

Quatsch. Oudere versies met security patches zijn niet kwetsbaar en v9.8 is niet nodig voor het patchen van kwetsbaarheden.

Als je een domme scan doet op x.y versienummers doe je geen scan waar iets betrouwbaars uit kan komen. Punt. Uit. Klaar. …

Mijn god, is dat muntje nog steeds niet gevallen bij die lui? Dat je inderdaad 'oudere' versies hebt die met security fixes veilig zijn gemaakt en dat je dus nooit alleen op basis van een versienummer kan concluderen dat iets onveilig is!
07-07-2024, 22:10 door Anoniem
Door Xavier Ohole:
Door Anoniem:
…scan…

Quatsch. Oudere versies met security patches zijn niet kwetsbaar en v9.8 is niet nodig voor het patchen van kwetsbaarheden.

Als je een domme scan doet op x.y versienummers doe je geen scan waar iets betrouwbaars uit kan komen. Punt. Uit. Klaar. …

Mijn god, is dat muntje nog steeds niet gevallen bij die lui? Dat je inderdaad 'oudere' versies hebt die met security fixes veilig zijn gemaakt en dat je dus nooit alleen op basis van een versienummer kan concluderen dat iets onveilig is!
Redhat doet dat inderdaad en is ook nog eens notabene partner met deze club.
RHEL 9 is de enige versie die effected is. Gekwalificeerd als belangrijk maar niet kritiek. Uitbuiting is heel moeilijk (Exploitation relies on an unpredictable race condition)
08-07-2024, 10:10 door Anoniem
Door Xavier Ohole:
Door Anoniem:
…scan…

Quatsch. Oudere versies met security patches zijn niet kwetsbaar en v9.8 is niet nodig voor het patchen van kwetsbaarheden.

Als je een domme scan doet op x.y versienummers doe je geen scan waar iets betrouwbaars uit kan komen. Punt. Uit. Klaar. …

Mijn god, is dat muntje nog steeds niet gevallen bij die lui? Dat je inderdaad 'oudere' versies hebt die met security fixes veilig zijn gemaakt en dat je dus nooit alleen op basis van een versienummer kan concluderen dat iets onveilig is!

Het zegt inderdaad NIETS over een individuele installatie, maar zegt wel degelijk iets over de orde van grootte van het voorkomen van de kwetsbaarheid.
08-07-2024, 13:31 door Xavier Ohole
Door Anoniem:
Door Xavier Ohole:
Door Anoniem:
…scan…
. Punt. Uit. Klaar. …

Mijn god, is dat muntje nog steeds niet gevallen bij die lui? Dat je inderdaad 'oudere' versies hebt die met security fixes veilig zijn gemaakt en dat je dus nooit alleen op basis van een versienummer kan concluderen dat iets onveilig is!

Het zegt inderdaad NIETS over een individuele installatie, maar zegt wel degelijk iets over de orde van grootte van het voorkomen van de kwetsbaarheid.

Hoe dan?
Reageren
Ondersteunde bbcodes
Bold: [b]bold text[/b]
Italic: [i]italic text[/i]
Underline: [u]underlined text[/u]
Quote: [quote]quoted text[/quote]
URL: [url]https://www.security.nl[/url]
Config: [config]config text[/config]
Code: [code]code text[/code]

Je bent niet en reageert "Anoniem". Dit betekent dat Security.NL geen accountgegevens (e-mailadres en alias) opslaat voor deze reactie. Je reactie wordt niet direct geplaatst maar eerst gemodereerd. Als je nog geen account hebt kun je hier direct een account aanmaken. Wanneer je Anoniem reageert moet je altijd een captchacode opgeven.